What to do if Images don’t change on the front-page #Prestashop 1.6

Published in Prestashop 1.6
I hope I can save you some pain if you are trying to edit/customise your images in Prestashop and find that the don’t change on the front page.
 
Default images not updating when edited on the front page of Prestashop
 
Has this happened to you? You edit the images in the Theme configuration module or under your preferences>theme and in the back office they are correct, but in the frontage they look like the default. So you browse for the images again and re-upload them but although the are correct in the back office they just won’t update on the prestashop frontage. What’s wrong? We’ll I’ll tell you.

Most likely if you have a problem with your Prestahiop installation not reflecting your image update even though you cleared the cache and re-uploaded them, the cause is probably a simple problem with the languages.
 
To check this, go to your Prestashop front page in your browser. Up on the top right you should see the language pull down menu. Test every language you have installed. Hopefully you will see the customised images suddenly appear when you change to a particular language. This is because Prestashop is saving images on a per language basis, they weren’t appearing on your front page because you had uploaded them for one language and we’re viewing them on the forntpage with the language set to a different one.
 
All you need to do know is to upload all the images in the right language. You can do this by going to your Prestashop back office and clicking preference>localisation (I think, I’m not using the English version) here you can change the default language and then upload all your images using the theme configuration module etc.
 
Then you can change all your images according to each install language and the images should appear on the Pretashop front page when that language is selected.
 
If you still have problems, check the following:
1) First check that the images appear correctly in the back office.
2) Clear your browser cache 
3) Clear your Prestashop cache
 
Lastly if your uploaded images still don’t appear on the front page then you may want to delete them from the /img folder in your Prestashop installation to force Prestashop to recreate them when you upload them again.