How to fix the “Failed to open a session for the virtual machine testing.” when you select Bridged adapter on Virtual Box in a Max OS X Mavericks environment.

Network settings adapter set to bridged virtual box mac os x mavericks
 
Let me guess the scenario: You are using Mavericks on an Apple Mac and running Virtual Box. You’ve suddenly discovered and error if you have a virtual machine Network adapter set to "Bridged Adapter". Maybe it wasn’t there before or maybe it’s your first install of this virtual machine, it doesn’t matter the virtual machine won't start and you get the error "Failed to open a session for the virtual machine testing.", sound familiar?
 
The good new is the fix is super simple. Just re-install virtual box (Download Virtual Box here).
 
Yup. Thats what did it for me. After tearing my hair out and playing with the virtual box network adapter settings. Nat worked but Bridged Didn’t ,all I got was the following gibberish, so when I found the fix I thought I’d share. Hope it works for you too.
 
Here is the error I got when trying to run a virtual Machine on Virtual box in Apple OS X Mavericks:
 
Failed to open a session for the virtual machine testing.
Failed to open/create the internal network 'HostInterfaceNetworking-en0' (VERR_SUPDRV_COMPONENT_NOT_FOUND).
Failed to attach the network LUN (VERR_SUPDRV_COMPONENT_NOT_FOUND).
 
Result Code:    NS_ERROR_FAILURE (0x80004005)
Component:    Console
Interface:    IConsole {db7ab4ca-2a3f-4183-9243-c1208da92392}